(Automated) Elevated error rates detected.

Incident Report for Encompass Technologies

Postmortem

Summary

On August 1, 2025, the DSDLink ECP website became unavailable for approximately 10 minutes. Our engineering team was immediately alerted, and the issue was promptly resolved.

Root Cause

The outage was triggered during a routine automated upgrade process for the system. A failure occurred while uploading a new software image to our container registry (AWS ECR), likely due to an internal networking issue at AWS. The deployment automation proceeded to update the live service with an incomplete test image.

Resolution

Our on-call engineer was alerted by our monitoring systems as soon as the issue occurred. They immediately began an investigation and were able to manually roll back the failed deployment and restore the previous, stable version of the website. Service was restored within 10 minutes of the initial alert.

Corrective and Preventative Actions

To prevent a recurrence of this issue, we have implemented the following improvements:

  1. Enhanced Deployment Logic: We have updated our automated deployment scripts. The system will now halt the upgrade process immediately if it detects any failure during the image upload to our container registry. This ensures that an incomplete or incorrect image can never be deployed to the production environment. This action was completed on August 1, 2025.
  2. Improved Monitoring: We are reviewing our monitoring and alerting to ensure even faster detection of similar deployment-related failures in the future.
Posted Aug 04, 2025 - 15:20 MDT

Resolved

This incident has been resolved, a post mortem will be posted in 5-7 business days
Posted Aug 01, 2025 - 04:26 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2025 - 01:23 MDT

Investigating

Encompass is investigating the elevated error rates. This incident will be updated as more information is discovered.
Posted Aug 01, 2025 - 01:13 MDT
This incident affected: Encompass Cloud Platform (ECP).