Issues loading site pages and syncing Encompass Mobile

Incident Report for Encompass Technologies

Postmortem

Summary

On Monday, July 7, 2025, some of our customers experienced a service disruption that prevented them loading the static content from our Content Delivery Network (CDN). The incident caused pages to be un-usable for users who had not loaded the cached content yet today, for approximately 43 minutes, depending on DNS delays. We have identified the root cause and have implemented a fix.

Timeline (All times MDT)

  • 11:45 AM: Our engineering team began investigating alarms from our monitoring services
  • 12:27 PM: The issue we were seeing for most customers with DNS issues resolved on its own as we were performing research. This indicated the issue was with a separate DNS provider outside our control. We continued to monitor for further issues.
  • 1:00 PM: Monitoring period complete and multiple reports confirmed issue was no longer present.

Root Cause

This issue was the first in a similar issue that occurred on July 8th, 2025. Please see that incident for a detailed assessment.

Resolution

The resolution to this was similar to that of the similar issue that happened on July 8th, 2025. Please see it for further detail.

Posted Jul 14, 2025 - 15:30 MDT

Resolved

From what we are seeing issues are largely resolved on their own. We'll continue to watch the issue.
Posted Jul 07, 2025 - 14:03 MDT

Monitoring

From our investigation, it looks like this was an issue with our content delivery network's DNS resolution, which has since resolved on its own. This was likely due to an intermittent networking issue in AWS's infrastructure.

We're continuing to monitor the issue.
Posted Jul 07, 2025 - 12:27 MDT

Investigating

We have received reports of issues with pages loading in Encompass and errors syncing Encompass Mobile. We are currently investigating and will update this task as we find out more information and can address the issue.
Posted Jul 07, 2025 - 11:57 MDT
This incident affected: Encompass Cloud Platform (ECP) and Encompass Mobile.