DSDLink system experiencing slowness and elevated error rates

Incident Report for Encompass Technologies

Resolved

Site performance is back to normal. We will continue to monitor, and investigate further later tonight.

We'll put up a post-mortem within 5-7 business days.
Posted Jun 16, 2025 - 13:06 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2025 - 12:38 MDT

Identified

We've identified some potential issues and are working on a fix for them.
Posted Jun 16, 2025 - 12:34 MDT

Investigating

Users are experiencing issues with degraded performance when creating and managing orders on the DSDLink site.

We are currently investigating the issue and will continue to post updates here.
Posted Jun 16, 2025 - 11:53 MDT
This incident affected: DSDLink.