Snowflake experiencing reliability issues

Incident Report for Encompass Technologies

Resolved

Snowflake has fully resolved their issue. There should be no further issues with Encompass functions that utilize Snowflake.

Snowflake will publish their own root cause analysis within five business days, which can be found on their site.
Posted Jun 22, 2026 - 18:40 MDT

Monitoring

Snowflake is rolling out a fix and Encompass is seeing decreased error rates across Snowflake and are monitoring to ensure performance continues to recover.
Posted Jun 22, 2026 - 16:27 MDT

Update

The Snowflake team is continuing to look into the issue, incident link: https://status.snowflake.com/incidents/zn8xxp2qzpr1
Posted Jun 22, 2026 - 15:55 MDT

Update

Snowflake has escalated this to an outage in the US Oregon Region
Posted Jun 22, 2026 - 14:41 MDT

Update

Snowflake team has added an incident to their own status page for monitoring: https://status.snowflake.com/
Posted Jun 22, 2026 - 14:40 MDT

Investigating

We are seeing increased error rates and slowness throughout Snowflake.
The Snowflake team is investigating.
Posted Jun 22, 2026 - 14:28 MDT
This incident affected: Snowflake Data Warehouse.