Snowflake experiencing reliability issues

Incident Report for Encompass Technologies

Resolved

Snowflake has resolved Encompass impacting issue. There should be no further issues with Encompass functions that utilize Snowflake.

Snowflake will publish their own root cause analysis within five business days, which can be found on their site.
Posted Jun 23, 2026 - 16:40 MDT

Investigating

We are seeing increased error rates and slowness throughout Snowflake.
The Snowflake team is investigating.

Snowflake team has added an incident to their own status page for monitoring: https://status.snowflake.com/incidents/j3xz9wrt22vp
Posted Jun 23, 2026 - 16:04 MDT
This incident affected: Snowflake Data Warehouse.