Data Warehouse queries running slower

Incident Report for Encompass Technologies

Resolved

Resolved, monitoring confirms Snowflake performance has returned to optimal state.
Posted Apr 02, 2026 - 13:14 MDT

Monitoring

The Snowflake service has recovered and we are monitoring it to confirm no further issues arise.
Posted Apr 02, 2026 - 12:04 MDT

Investigating

We are currently investigating this issue, appears to be a slow down in the Snowflake provider.
Posted Apr 02, 2026 - 11:23 MDT
This incident affected: Snowflake Data Warehouse.