Increased 5xx error rate and slowness for some users

Incident Report for Encompass Technologies

Resolved

This incident has been resolved. We will provide a post-mortem within 5-7 business days for this incident, once we conclude our investigation.
Posted Jul 02, 2025 - 18:01 MDT

Monitoring

We've implemented a fix and service has been restored. We are continuing to monitor the infrastructure.
Posted Jul 02, 2025 - 17:35 MDT

Investigating

We are currently investigating issues with increased 5xx errors and slowness on the Encompass application affecting some users. We will continue to update this incident periodically.
Posted Jul 02, 2025 - 17:30 MDT
This incident affected: Encompass Cloud Platform (ECP).