"VerifySession_Fail" error pops up for users with eChat permission

Incident Report for Encompass Technologies

Postmortem

Summary

On January 29, 2026, our eChat service experienced an intermittent disruption that impacted user communication and system stability. Users may have encountered persistent "SyncData2010_Fail Session Expired" pop-up messages and experienced difficulties sending or receiving messages, loading chat history, or initiating new sessions. Our engineering and CRM teams worked together to identify and resolve the issue, restoring full service functionality.

Timeline

All times are in MST on January 29, 2026:

  • Around 10:12 AM: The system detected an unusually high number of server errors (5XX) on the eChat web server.
  • Shortly after detection: Users began reporting "Session Expired" pop-ups and chat failures.
  • Throughout the morning: Technical teams attempted to restart core web and socket services; however, the issue intermittently reappeared.
  • Around 12:55 PM: Investigation pinpointed a communication failure between the eChat server and its internal components.
  • Around 1:03 PM: Remediation steps were completed, and the service returned to normal.

Root Cause

The incident was caused by an incorrect system configuration. Specifically, during a routine update or background process, the eChat service began utilizing an incorrect test configuration file instead of the required production settings. This caused the system to look for data in the wrong locations and prevented the eChat web server from successfully connecting to the internal servers responsible for maintaining active chat sessions.

Resolution

To resolve the incident, our DevOps team redeployed the eChat service with the correct production configuration. This fresh deployment cleared the invalid settings and restored the necessary connections between our internal components. Following the redeployment, we monitored the environment closely to ensure the "Session Expired" errors ceased and that 5XX error counts returned to healthy levels. We are currently reviewing our deployment pipeline to prevent incorrect configuration files from being applied to production environments in the future.

Posted Feb 02, 2026 - 13:08 MST

Resolved

This incident has been resolved. We will be reviewing the issue and provide a post-mortem within 5-7 business days.
Posted Jan 29, 2026 - 13:42 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2026 - 13:05 MST

Update

We are continuing to investigate this issue.
Posted Jan 29, 2026 - 12:09 MST

Investigating

We are aware of an issue causing a "VerifySession_Fail" error to appear on ECP sites for users with eChat permissions.

This does not impact site functionality or your data, other than the eChat icon in the corner likely not working. We are currently investigating the cause, but you can safely dismiss the popup and continue using the site as normal.
Posted Jan 29, 2026 - 10:35 MST
This incident affected: Encompass Cloud Platform (ECP).