Mileage Tracker service displaying 403 errors for some customers

Incident Report for Encompass Technologies

Postmortem

Summary

On August 21st, 2025, our Mileage Tracker application experienced a service disruption that prevented users from accessing their dashboards. The issue began at approximately 8:40 AM MST and was fully resolved by 9:55 AM MST. We apologize for the inconvenience this may have caused.

Timeline

  • Around 8:40 AM MST: We started receiving reports of users being unable to access the Mileage Tracker dashboard, with an error message displaying.
  • Shortly after: Our engineering team was alerted and began investigating the cause of the problem.
  • Around 9:45 AM MST: We identified the root cause and began working on a solution.
  • Around 9:55 AM MST: A temporary fix was implemented, and full service was restored for all users.

Root Cause

The incident was caused by a newly deployed security rule for our Web Application Firewall. This rule, which was intended to protect the application, was inadvertently enabled before it was fully tested. As a result, it mistakenly identified legitimate user requests as malicious and blocked them from reaching the dashboard.

Resolution

To resolve the issue, our team immediately disabled the problematic security rule, which restored full access to the Mileage Tracker application. The rule has since been corrected and re-enabled following proper testing. We are also implementing an improved process to ensure that all future security and system changes are thoroughly vetted and tested before being deployed to prevent similar incidents.

Posted Aug 21, 2025 - 20:52 MDT

Resolved

We have confirmed the incident resolved, and Mileage Tracker is fully functional. We'll provide a post-mortem within 5-7 business days.
Posted Aug 21, 2025 - 10:11 MDT

Monitoring

Mileage Tracker service is working for customers now. We'll continue to monitor the situation until we've confirmed full service recovery.
Posted Aug 21, 2025 - 09:58 MDT

Investigating

We are currently investigating an issue where Mileage Tracker is displaying alerts and not getting data.
Posted Aug 21, 2025 - 09:56 MDT
This incident affected: Encompass Cloud Platform (ECP).