Issues loading site pages and syncing Encompass Mobile

Incident Report for Encompass Technologies

Resolved

We've started to receive reports that issue is resolving for affected users. Any remaining users should see service return to normal in within the next 1-2 hours.
Posted Apr 17, 2026 - 10:27 MDT

Update

We are continuing to monitor for any further issues.
Posted Apr 17, 2026 - 09:56 MDT

Monitoring

From our investigation, it looks like this may be an issue with select Internet Service Providers (ISP), and not a broader issue with the Encompass system.

If you experience an issue, please try using a different Wi-Fi network to connect to the application.

We will continue to monitor the issue.
Posted Apr 17, 2026 - 09:56 MDT

Investigating

We have received reports of issues with pages loading in Encompass and errors syncing Encompass Mobile. We are currently investigating and will update this task as we find out more information and can address the issue.
Posted Apr 17, 2026 - 09:00 MDT
This incident affected: Encompass Cloud Platform (ECP) and Encompass Mobile.